Avvio lento di fedora 16

Ritratto di Kodiak
Kodiak
(Junior)
Offline
Junior
Iscritto: 21/04/2012
Messaggi: 18

Diciamo che prima cerco di accertarmi che non siano processi fondamentali. Poi sempre in quel blog che dicevo ho trovato un minimo di spiegazione dei processi..

Nel computer ho fedora e windows7, la swap si condivide solo tra sistemi linux?

L'avvio dopo aver disabilitato quei processi non è particolarmente lento (poco più di un minuto), non mi convince il fatto di avere quel processo così lento rispetto agli altri.
Si pianta un po' nello splash e dopo aver inserito la password di login però sai è tutto realtivo...

grazie mille intanto

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Citazione:

Nel computer ho fedora e windows7, la swap si condivide solo tra sistemi linux?

Citazione:

L'avvio dopo aver disabilitato quei processi non è particolarmente lento (poco più di un minuto),

Controlla il log che trovi in /var/log/boot.log.

Ritratto di Kodiak
Kodiak
(Junior)
Offline
Junior
Iscritto: 21/04/2012
Messaggi: 18

Ecco non sapevo come si poteva controllare i processi...

questo è il fail che mi da:

Failed to start LSB: Builds and install new kmods from akmod packages [FAILED]
See 'systemctl status akmods.service' for details.

poi:

# systemctl status akmods.service
akmods.service - LSB: Builds and install new kmods from akmod packages
Loaded: loaded (/etc/rc.d/init.d/akmods)
Active: failed since Sat, 21 Apr 2012 14:39:15 +0200; 1h 4min ago
Process: 1038 ExecStart=/etc/rc.d/init.d/akmods start (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/akmods.service

non saprei però da dove rifarmi!!

grazie dell' aiuto

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

E' un classico. Il servizio akmods è usato per compilare automaticamente dei moduli kernel come i catalyst, gli nvidia, i VirtualBox-OSE, ...

Vediamo cosa hai di installato:

$ rpm -qa | grep -e kmod -e kernel

Ritratto di Kodiak
Kodiak
(Junior)
Offline
Junior
Iscritto: 21/04/2012
Messaggi: 18

ecco qua:

kernel-3.3.1-5.fc16.i686
abrt-addon-kerneloops-2.0.7-2.fc16.i686
libreport-plugin-kerneloops-2.0.8-4.fc16.i686
kernel-3.3.1-3.fc16.i686
kernel-3.3.2-1.fc16.i686
kmodtool-1-18.fc11.noarch
akmods-0.3.8-3.fc16.noarch
kernel-headers-3.3.2-1.fc16.i686
kernel-devel-3.3.1-3.fc16.i686
kernel-devel-3.3.1-5.fc16.i686
kernel-devel-3.3.2-1.fc16.i686

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

$ su -c 'systemctl disable akmods.service'

Riavvìa.

Ritratto di Kodiak
Kodiak
(Junior)
Offline
Junior
Iscritto: 21/04/2012
Messaggi: 18

fatto! ora ricontrollando i processi con cat var/log.... non ci sono più fail ora, dedurrei quindi che è tutto a posto.
però mi sembra che all'avvio non ci siano molte differenze...

Per caso fedora-storage-init-late.service è collegato a cose tipo ipv6 e firewall? perchè ho visto che quando viene disabilitato vengono prima disattivati/disinstallati ipv6 e firewall, io però non ho voluto prendere decisioni azzardate.. trovandomi poi in vie di non ritorno!!

ciao

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

$ systemctl status fedora-storage-init-late.service
fedora-storage-init-late.service - Initialize storage subsystems (RAID, LVM, etc.)
	  Loaded: loaded (/usr/lib/systemd/system/fedora-storage-init-late.service; static)
	  Active: active (exited) since Mon, 23 Apr 2012 12:13:18 +0200; 2min 23s ago
	 Process: 493 ExecStart=/lib/systemd/fedora-storage-init (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/fedora-storage-init-late.service

Nella prima riga dell'output ti dice a cosa serve il servizio.Se non usi il RAID o l'LVM, puoi disabilitarlo.

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

sagitter ha scritto:

$ systemctl status fedora-storage-init-late.service
fedora-storage-init-late.service - Initialize storage subsystems (RAID, LVM, etc.)
	  Loaded: loaded (/usr/lib/systemd/system/fedora-storage-init-late.service; static)
	  Active: active (exited) since Mon, 23 Apr 2012 12:13:18 +0200; 2min 23s ago
	 Process: 493 ExecStart=/lib/systemd/fedora-storage-init (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/fedora-storage-init-late.service

Nella prima riga dell'output ti dice a cosa serve il servizio.Se non usi il RAID o l'LVM, puoi disabilitarlo.

Mi sono informato meglio sui servizi fedora-storage-init*.service perché ho notato che nonostante si cerchi di disabiltarli, comunque si riavviano al successivo boot di Fedora.
In realtà queto tipo di servizi sono staticamente abilitati da systemd (notare static nella seconda riga dell'output) che vuol dire attualmente non possono essere disabilitati. Il fatto è riconducible ai pacchetti initscript che contengono link ai servizi in oggetto che verranno quindi comunque avviati anche se non si usano sistemi LVM o RAID

/lib/systemd/system/local-fs.target.wants/fedora-storage-init-late.service
/lib/systemd/system/local-fs.target.wants/fedora-storage-init.service

Effettivamente la scansione dei filesystem rallenta l'avvìo di Fedora ma credo che attualmente non possa essere evitata.

Ritratto di Kodiak
Kodiak
(Junior)
Offline
Junior
Iscritto: 21/04/2012
Messaggi: 18

Ho dato una letta a quei link ma sinceramente ci ho capito poco... comunque non penso di aver abilitato nulla di più delle impostazioni di default.

Effettivamente prima di disabilitarlo avevo fedora-storage-init.service che poi è stato sostituito da l'altro.

Quando lo ritrovo posto il link di quel blog che ti dicevo. Se nel frattempo trovi qualche soluzione, aggiornami pure.

comunque intanto grazie