Gnome 3 non si avvia sia da Live CD che dopo aver installato Fedora 15

22 risposte [Ultimo messaggio]
Ritratto di Aliquo93
Aliquo93
(Junior)
Offline
Junior
Iscritto: 30/09/2011
Messaggi: 13

Salve a tutti, ho installato correttamente Fedora 15 con Gnome 3 funzionante su un Acer Aspire One (che ha come chip grafico l'Intel 945 GME). Però tentando di installarlo su un altro portatile montante chip grafico Intel 945 GM, Gnome 3 non va nè da Live CD, nè una volta installato Fedora su disco fisso (al posto di Gnome 3 viene caricata la modalità di fallback). Non riesco a capire come mai faccia così dato che su quel portatile fino a qualche mese fa utilizzavo correttamente Gnome 3 con Ubuntu. Qualcuno saprebbe aiutarmi? Grazie in anticipo a tutti! Big Grin

Ritratto di amontag
amontag
(Monster)
Offline
Monster
Iscritto: 06/01/2011
Messaggi: 446

prova ad avviare con l'opzione nomodeset nella riga del grub, poi aggiorna il portatile e riporta quello che è successo!!!

antonio m

Ritratto di Aliquo93
Aliquo93
(Junior)
Offline
Junior
Iscritto: 30/09/2011
Messaggi: 13

Niente, si avvia sempre in modalità fallback... ma comunque secondo me è un problema di driver...

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Esiste lo xorg.conf ?

$ cat /etc/X11/xorg.conf

Ritratto di Aliquo93
Aliquo93
(Junior)
Offline
Junior
Iscritto: 30/09/2011
Messaggi: 13

[daniele@PC-Daniele ~]$ cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

A quanto pare no.

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Crealo.

- Al boot seleziona il kernel che usi
- premi e
- alla fine della riga kernel aggiungi 3
- invio
- premi b

quando appare 'Login', loggati come root e digita:

# X -configure
# cp /root/xorg.conf.new /etc/X11/xorg.conf
# reboot

Il PC si riavvierà.

Ritratto di Aliquo93
Aliquo93
(Junior)
Offline
Junior
Iscritto: 30/09/2011
Messaggi: 13

[daniele@PC-Daniele ~]$ cat /etc/X11/xorg.conf
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	Screen      1  "Screen1" RightOf "Screen0"
	Screen      2  "Screen2" RightOf "Screen1"
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "catalogue:/etc/X11/fontpath.d"
	FontPath     "built-ins"
EndSection
 
Section "Module"
	Load  "record"
	Load  "dri"
	Load  "dbe"
	Load  "extmod"
	Load  "dri2"
	Load  "glx"
EndSection
 
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection
 
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection
 
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection
 
Section "Monitor"
	Identifier   "Monitor1"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection
 
Section "Monitor"
	Identifier   "Monitor2"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
EndSection
 
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "AccelMethod"        	# [<str>]
        #Option     "DRI"                	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "Tiling"             	# [<bool>]
        #Option     "Shadow"             	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
        #Option     "HotPlug"            	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
EndSection
 
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "Rotate"             	# <str>
        #Option     "fbdev"              	# <str>
        #Option     "debug"              	# [<bool>]
	Identifier  "Card1"
	Driver      "fbdev"
	BusID       "PCI:0:2:0"
EndSection
 
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "DefaultRefresh"     	# [<bool>]
        #Option     "ModeSetClearScreen" 	# [<bool>]
	Identifier  "Card2"
	Driver      "vesa"
	BusID       "PCI:0:2:0"
EndSection
 
Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
Section "Screen"
	Identifier "Screen2"
	Device     "Card2"
	Monitor    "Monitor2"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
[daniele@PC-Daniele ~]$ 

Eccolo qua... comunque non ho detto una cosa che magari può essere d'aiuto: io al portatile ho connesso una TV come monitor tramite l'uscita VGA, poichè il monitor originale si era rotto e l'ho staccato.

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Il nomodeset è ancora presente nella riga kernel di Grub ?

Ritratto di Aliquo93
Aliquo93
(Junior)
Offline
Junior
Iscritto: 30/09/2011
Messaggi: 13

Scusa se rispondo solo ora, comunque no, non è presente.

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

La tua è una situazione piuttosto atipica; prova con queste modifiche a questa parte dello xorg.conf (tutto il resto rimane uguale):

...
Section "Screen"
	Identifier "Screen1"
	Device     "Card0"
	Monitor    "Monitor1"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
Section "Screen"
	Identifier "Screen2"
	Device     "Card0"
	Monitor    "Monitor2"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Ritratto di Aliquo93
Aliquo93
(Junior)
Offline
Junior
Iscritto: 30/09/2011
Messaggi: 13

Scusa non ho ben capito la parte da modificare, visto che "Section screen" si ripete più volte nel file.