Plymouth boot grafico con driver nvidia proprietario

Ritratto di fdaluisio
fdaluisio
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 506

Partirei a testa basta con un runlevel 3 e una rimozione immediata del driver nvidia installato da .run (osceno).
Poi installerei i driver nvidia da fusion così da portarti nella situazione in cui la keyword vga funziona

Se ti trovi durante il procedimento che Xorg non parte sostituisci temporaneamente la dicitura:

driver "nvidia"

con

driver "vesa"

In /etc/X11/xorg.conf come root.
Quando hai installato i driver nvidia da fusion torniamo a discutere del problema boot grafico.

Ritratto di Cielito
Cielito
(Geek)
Offline
Geek
Iscritto: 03/03/2011
Messaggi: 166

fdaluisio ha scritto:

(osceno)


Osceno (lo dico col sorriso in bocca, nessuna polemica o offesa per nessuno) è il fatto che installando i driver nvidia da rpmfusion (quindi con la procedura yum install akmod nvidia ecc ecc) io NON POSSA (come ho già detto in un post precedete che ha sucscitato tanto scalpore) LAVORARE. Il software che uso per il cad (bricscad-proprietario) non si apre. Ho fatto presente il fatto alla sociatà che lo produce ma ad oggi nessun cambiamento. I driver nouveau mi tengono la ventola della SV sempre accesa e in movimento, quindi rischierei di bruciarla, con quello che costa.
Quindi: soluzione akmod-nvidia=> non lavoro
soluzione nouveau=> non lavoro
Alte soluzioni cad (DraftSight) le sto utilizzando, seppur con grande difficoltà e lentezza nel lavoro, ma almeno ci provo a trovare soluzioni alternative.

Ditemi voi ora cosa dovrei fare. Forse rinunciare a plymoith mi sembra la soluzione più ragionevole. La più ovvia sarebbe tornare a windows in cui non ho mai avuto nessun tipo di problema. Ma questo non lo farò mai!

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Non vedo come si colleghi tutto ciò con plymouth ...

Riordina il tuo sistema poi ne riparliamo.

Ritratto di fdaluisio
fdaluisio
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 506

Ero rimasto alla macchina di casa. Ma se allora è la macchina dell'ufficio perchè la smanetti così tanto?

Se il programma di cad non parte è possibile che dipenda dalla mancanza di un qualche link o si aspetta una qualche libreria da qualche parte.

Il driver installato da fusion è il driver nvidia ripachettizzato per essere aggiornabile nel pieno rispetto del policy di rilascio di rpmfusion.
Non un blob come lo rilascia nvidia che nelle sue volontà vorrebbe essere cross-distribuzione.

Posso capire che per un cad il driver nouveau (tra l'altro distribuito in kernel quindi non puoi rimuoverlo se non cancelli fisicamente il file oppure rimuovi
il kernel) non sia sufficiente.

Non mi spiego questa diversità di comportamento tra i .run di nvidia e la pachettizzazione di rpmfusion.

Ritratto di Cielito
Cielito
(Geek)
Offline
Geek
Iscritto: 03/03/2011
Messaggi: 166

fdaluisio ha scritto:

Non mi spiego questa diversità di comportamento tra i .run di nvidia e la pachettizzazione di rpmfusion.


Figurati io. Riporto solo la mia esperienza, pur sentendomi un Don Dhisciotte.

Ritratto di Cielito
Cielito
(Geek)
Offline
Geek
Iscritto: 03/03/2011
Messaggi: 166

sagitter ha scritto:

Non vedo come si colleghi tutto ciò con plymouth ...


Ho provato a spiegarlo. Evidentemente non ci sono riuscito. Non so che altro fare per spiegare la difficoltà che si ha nel mio campo, con questo sistema. L'unica soluzione che avevo trovto era quella appena descritta che fino a fedora 14 andava egregiamente. Adesso nn più, sembrerebbe.

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Citazione:

Osceno (lo dico col sorriso in bocca, nessuna polemica o offesa per nessuno) è il fatto che installando i driver nvidia da rpmfusion (quindi con la procedura yum install akmod nvidia ecc ecc) io NON POSSA (come ho già detto in un post precedete che ha sucscitato tanto scalpore) LAVORARE. Il software che uso per il cad (bricscad-proprietario) non si apre. Ho fatto presente il fatto alla sociatà che lo produce ma ad oggi nessun cambiamento. I driver nouveau mi tengono la ventola della SV sempre accesa e in movimento, quindi rischierei di bruciarla, con quello che costa.
Quindi: soluzione akmod-nvidia=> non lavoro
soluzione nouveau=> non lavoro

Tanto per documentare ciò che vado dicendo, posto due link a due video appena fatti per dimostrare che Bricscad è avviabile sia su Fedora provvista di driver proprietari sia provvista di driver open Nouveau.

Nouveau nVidia

Ritratto di Cielito
Cielito
(Geek)
Offline
Geek
Iscritto: 03/03/2011
Messaggi: 166

Che sia avviabile già lo sappiamo. Dipende in che modo sono stati installati e che prestazioni garantiscono. Credo che tu abbia perso un po' del tuo tempo prezioso...
In questo modo dimostri la tua bravura e la tua competenza. Un ego decisamente massiccio, ti faccio i complimenti. Peccato che tu non aiuti un utente che è qui per chiedere aiuto alla famosa e accogliente comunità Linux. dimostrando che questo utente sia un deficiente che non è capace di farlo da solo.

Ritratto di sagitter
sagitter
(Collaboratore)
Offline
Collaboratore
Iscritto: 04/01/2011
Messaggi: 1320

Ti consiglio di impegnarti di più in quello che fai e a parlare di meno soprattutto.

Il mio intento è quello di NON fare disinformazione, non devo dimostrare nulla.

Spero di non buttare via il mio tempo in questa discussione.

Ritratto di Cielito
Cielito
(Geek)
Offline
Geek
Iscritto: 03/03/2011
Messaggi: 166

sagitter ha scritto:

Ti consiglio di impegnarti di più in quello che fai e a parlare di meno soprattutto.


Stesso consiglio lo faccio io a te. Ancora devi darmi delle riposte alle mie domande nei post precedenti. Non mi stai aiutando.